Skip to main content
Power BI (Beta)

Learn how to enter the beta phase integration of Falcon and Power-BI

Moritz Mußmann avatar
Written by Moritz Mußmann
Updated over a week ago

With the help of our special connector, Power BI and Falcon can be connected natively. This allows you to fill your Power BI dashboards directly with data from your Falcon Hub at any time without an import/export process. Once installed, the connector ensures that your reports and dashboards in PowerBI are always up to date.

To avoid possible errors when working with Power BI and Falcon, we strongly recommend using Power BI 64-bit version.


This article will explain:


1. Installation

Download Custom Connector

In order to use Falcon as a source in Power BI, you need a so-called Custom Connector, available for download here:


Place the Falcon.mez file in the Custom Connectors folder.

Now you have to place the Connector you have just downloaded in a special location.

To do this, click on the file folder in your "C" drive on Documents (1). If there is no folder named Power BI Desktop there, you must create a new folder and in it the folder Custom Connectors, so that the file path Documents\Power BI Desktop\Custom Connectors (2) is created. Now place the file Falcon.mez in this folder (3).

The path should be the same as described. Depending on the setup of your environment, it may also be called C:\Users\Username\Documents\Power BI Desktop\Custom Connectors or similar.


Change Power BI settings

Since the connection between Power BI and Falcon is currently in the beta phase, the Connector must now be permitted explicitly as a source.

  • To do this, open Power BI and click on File > Options and Settings (1) > Options (2) at the top left.



  • Now click on the Security tab (2) and select the option (Not recommended) Allow any extension to load without valitadtion or warning (4). Confirm with OK (5) and restart Power BI so that the new settings take effect.



Create access tokens in Falcon

It doesn't take much to use Falcon as a source in Power BI. To establish this connection, you need a so-called Personal Access Token on Falcon.

  • In the Falcon menu (1), click Development > Personal Access Tokens (2).



  • Now click on the + symbol (3) to create a new token.

  • Give the token for Power BI a distinct name (4) and select a validity period (5).

  • Now you need to enter your Falcon password (6) - the password you use to log in to Falcon - and save it (7).



  • The new token is now displayed. Click on the blue copy symbol (8) to save the token to the clipboard.



Set up the Connector in Power BI

Now you are ready to use Falcon as a source in Power BI! Falcon is ready for you as "another source".

  • Click on Get Data (1) > More... (2)



  • Enter Falcon (3) in the search field to quickly find the Falcon connector (4).


  • Select Falcon (4) and "Connect" (5).

  • Now enter the e-mail address (6) with which you log into Falcon as the user name.

  • In the Personal access token field, insert the token (7) that you created earlier in Falcon.



  • Now select all tables (9) and click on Load (10).


Now all data is available live from Falcon and you can start creating any dashboards and analyses using Power BI.


2. Using Falcon & Power BI

Create Datamodel & Relationships

When the connector is loaded for the first time, Power BI automatically creates relationships between the tables.

However, Power BI does not recognise all the necessary relationships between the tables. Therefore, you need to configure these relationships once before creating a new dashboard:

  • Click on Model View (1) and zoom out to show all tables (2).


  • Now arrange the tables as shown in the screenshot:


  • Now drag Date (3) in the Calendar table and drop Date onto Period (Start) in the Effects table (4) to create one of the missing relationships.


  • Repeat the process for the following relationships:

  • Date from the Calendar table to Created at from the Status table.


  • Date from the Calendar table to End (Plan) from the Schedule table.


  • User (ID) from the Users table to Resposible (ID) from the Profiles table.


Working with sample dashboard

Download the sample dashboard and save it on your computer in a folder of your choice :

Double-click on the [Template.pbix] file to automatically open the sample dahboard with Power BI.If this should not be the case, right-click on the file and select Open with > Power BI Desktop.


Create Datamodel & Relationships

If you want to create the data model completely from scratch and do not want to work with one of our templates, it is essential that you create missing relationships between individual tables that Power BI does not automatically recognize when loading the connector for the first time.

Proceed as follows:

  • Click on Model View (1) and zoom out to show all tables (2).


  • Now arrange the tables as shown in the screenshot:


  • Now drag Date (3) in the Calendar table and drop Date onto Period (Start) in the Effects table (4) to create one of the missing relationships.


  • Repeat the process for the following relationships:

  • Date from the Calendar table to Created at from the Status table.


  • Date from the Calendar table to End (Plan) from the Schedule table.


  • User (ID) from the Users table to Resposible (ID) from the Profiles table.


3. Tips & Tricks for Creating GFX

Use effect Totals

The Power Bi Connector (Beta) provides you with a variety of aggregated effect values. For most visualisations, you will probably need the actual value entered in Falcon for the respective effect in the corresponding period - the effect total.

This value can be quickly and easily recognised by the Total symbol ∑:


Hide unused measured values in the data view

With the large amount of measurements provided by the Connector to Falcon, it can quickly become a little cluttered.

If you notice that you do not use certain measurements at all, you can simply hide them.

  • Go to the data view (1) and expand the table (2) containing the measurement you want to hide.

  • Click on the eye symbol to the right of the measured value (3) to hide it.


Remove values aggregated in Falcon with filter of the graph

Sooner or later you will create a chart in which the values displayed do not match the data in Falcon.

The reason for this is very often that data that has already been aggregated in Falcon appears in the chart.On the one hand, "blank" data might be included in the chart.


A quick look at the data view shows where the blank values come from. They are actually higher levels of aggregation in Falcon.


You can easily remove this data via the filter for the corresponding diagram:

  • In the filter menu, right-click on the measured value or dimension where the blank data appears (1).

  • Select the filter type Advanced Filtering (2) and in the next dropdown is not blank (3).

  • Finally you have to click on Apply Filter.


Unfortunately, the values still do not match the data in Falcon.

In this example, we want to display the data by project. However, the data of the subordinate levels (packages & measures) have not yet been filtered out. Therefore, these are also displayed.

To filter out the subordinate levels, you must filter by type.

  • Search for Type (1) in the Profiles table.

  • Drag the Type field into the filter area for the diagram (2).

  • Select only the layer you want to show in the diagram (3).

Did this answer your question?